Feb 16th Important Technical Alert for WordPress Users

WordPress earlier versions are affected by security issues and it is highly recommended that users upgrade to the latest released version without delay. Last week, the WordPress project issued an update that had a flaw in it. It was caught almost immediately and within a few hours a patch was released. As WordPress states in their blog ... Read More »